Scantist CSA: Curated Security Advisory (6 May 2021)

Scantist CSA: Curated Security Advisory (6 May 2021)

Scantist Admin

Scantist Admin

- Curated Security Advisory

Scantist CSA:
Curated Security Advisory (6 May 2021)

Data is crawled between 28 Apr to 5 May 2021

Java

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
com.fasterxml.jackson.core:jackson-databind128.1<2.9.10.8
com.thoughtworks.xstream:xstream119.9<=1.4.15
apache:ofbiz39.8<17.12.07
org.apache.unomi:unomi-services29.8<=1.5.1
com.alibaba.nacos:nacos-client20*<1.4.1
com.vaadin:flow-server22.51.0.0 – 1.0.13, 1.1.0 – 2.4.6, 3.0.0 – 5.0.2
org.apache.tika:tika25.5<=1.25
org.apache.unomi:unomi-persistence-elasticsearch-core29.8<=1.5.1
org.apache.unomi:unomi-plugins-base29.8<=1.5.1
org.apache.pdfbox:pdfbox25.52.0.0 – 2.0.22
org.apache.unomi:unomi-root19.8<=1.5.1
org.darkphoenixs:log4j19.8<=1.2.17
org.apache.unomi:unomi-wab19.8<=1.5.1
org.apache.unomi:unomi19.8<=1.5.1
org.eclipse.jetty:jetty-project12.79.4.32 – 9.4.38, 10.0.0.beta2 – 10.0.1, 11.0.0.beta2 – 11.0.1
org.eclipse.jetty:jetty-webapp17<=9.4.32.v20200930, 10.0.0 – 10.0.0.beta2, 11.0.0 – 11.0.0.beta2
org.openapitools:openapi-generator10*<5.1.0
org.apache.unomi:unomi-kar19.8<=1.5.1
org.apache.tapestry:tapestry-core10*5.4.0 – 5.6.3, 5.7.0 – 5.7.1
org.apache.unomi:shell-commands19.8<=1.5.1
apache:tomcat14.87.0.0 – 7.0.99, 8.5.0 – 8.5.50, 9.0.0m1 – 9.0.30
org.apache.shiro:shiro-spring19.81.7.0
org.apache.maven:maven-core10*< 3.8.1
org.apache.logging.log4j:log4j-core19.8<2.8.2-rc1
org.apache.druid:druid-core18.8<0.21.0
log4j:log4j19.81.2 – 1.2.17
dotcms:dotcms15.45.1.5
commons-io:commons-io15.3<2.7
com.vaadin:vaadin-server12.57.0.0 – 7.7.23, 8.0.0 – 8.12.2
org.sonatype.nexus:nexus-repository10*3.0 – 3.30.1


JavaScript

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
etherpad:etherpad40*<1.8.3
jquery26.11.2 – 3.4.1
@ckeditor/ckeditor5-font10*<=26.0.0
ueberdb210*<0.4.4
safe-obj19.81.0.0 – 1.0.2
redis17.52.6.0 – 3.1.0
node-mydomoathome10*0.2.4
mootools-more-dist18.81.6.0
mixme10*<=0.5.0
jquery-deparam18.80.5.1
jquery-bbq19.81.2.1
ghost10*4.0.0 – 4.3.2
@ckeditor/ckeditor5-engine10*<=26.0.0
elasticsearch14.37.6.0 – 7.11.0
browserlist10*4.0.0 – 4.16.4
backbone-query-parameters18.80.4.0
@prisma/sdk10*<2.20.0
@ckeditor/ckeditor5-widget10*<=26.0.0
@ckeditor/ckeditor5-paste-from-office10*<=26.0.0
@ckeditor/ckeditor5-media-embed10*<=26.0.0
@ckeditor/ckeditor5-markdown-gfm10*<=26.0.0
@ckeditor/ckeditor5-list10*<=26.0.0
@ckeditor/ckeditor5-image10*<=26.0.0
xmlhttprequest-ssl17.4<1.6.1


Python

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
apache_airflow36.1<1.10.15, 2.0.0 – 2.0.2rc1
ansible27.5<2.8.18rc1, 2.9.0 – 2.9.17, 2.10.0 – 2.10.6
babel17.82.9.0
django_filter10*<2.4.0
salt10*<=3002.6
wagtail14.8<2.11.6, 2.12 – 2.12.3


1 Affected Library refers to the open source library that contains newly disclosed CVEs.

2 # of CVEs refers to number of newly disclosed CVEs over the past week.

3 Highest CVE Score refers to the highest CVSS Score amongst the newly disclosed CVEs over the past week. Those omitted in dashes are yet to be determined by MITRE and NVD.

4 Affected versions refers to the versions of affected library that contains the newly disclosed CVEs.



Affected libraries may also exist in your transitive dependencies.

Let Scantist help you identify your dependencies and vulnerabilities immediately. Sign up for free and start scanning now.

We support other languages upon request. Subscribe to receive our weekly CSA alerts straight to your inbox.