Scantist CSA: Curated Security Advisory (6 Jan 2022)

Scantist CSA: Curated Security Advisory (6 Jan 2022)

Scantist Admin

Scantist Admin

- Curated Security Advisory

Scantist CSA:
Curated Security Advisory (6 Jan 2022)

Data is crawled between 30 Dec 2021 to 5 Jan 2022

Java

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
org.apache.logging.log4j:log4j-core26.62.0.0, 2.0-alpha1 - 2.17.0
ch.qos.logback:logback-classic16.6<1.2.9, 1.3.0-alpha0 - 1.3.0-alpha10
org.keycloak:keycloak-authz-client15.5<=8.0.2
org.webjars:angularjs17.51.4.0-beta.6 - 1.7.8
org.webjars.npm:angular17.51.4.0-beta.6 - 1.7.8
org.webjars.bower:github-com-angular-angular-js17.51.4.0-beta.6 - 1.7.8
org.webjars.bower:angularjs17.51.4.0-beta.6 - 1.7.8
org.springframework:spring-webmvc15.35.2.0.RELEASE - 5.2.2.RELEASE
org.springframework:spring-webflux15.35.2.0.RELEASE - 5.2.2.RELEASE
org.jboss.resteasy:resteasy-jaxrs17.53.0.0 - 3.11.5.Final
com.h2database:h219.1<=1.4.200
org.jboss.resteasy:resteasy-core17.53.0.0 - 3.11.0.Final, 4.0.0 - 4.0.5
org.apache.parquet:parquet17.5<=1.11.1, 1.12.0 - 1.12.1
org.apache.nifi:nifi-parameter15.3<=1.10.0
org.apache.logging.log4j:log4j16.62.0.0, 2.0.1 - 2.3.1, 2.13.0 - 2.17.0
net.sourceforge.htmlunit:htmlunit18.1<=2.36.0
org.webjars:jquery.terminal13.7<=0.9.3


JavaScript

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
mediawiki57.51.31.0 - 1.31.9, 1.32.0 - 1.34.3
angularjs17.51.4.0-beta.6 - 1.7.8
compile-sass18.2<=1.0.4
cordova-plugin-camera13.3<=4.1.0
csv-parse17.5<=4.4.5
html-pdf17.52.2.0
joplin15.4<=1.0.184
jquery.terminal13.7<=2.31.0
jsx-slack17.5<=4.5.1
mermaid17.2<=8.13.8
netmask19.1<=1.0.6
node-windows19.8<1.0.0-beta.5
mediawiki57.51.31.0 - 1.31.9, 1.32.0 - 1.34.3


Python

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
salt49.82015.8.9, 015.8.11 - 2015.8.12, 2016.11.6 - 2016.11.9, 2016.3.0 - 2016.3.3, 2016.3.5, 2016.3.7, 2016.3.9 - 2017.7.7, 2018.2.0 - 2018.3.5, 2019.2.0.0rc2 - 2019.2.4, 2019.2.6 - 3000.5, 3000.9 - 3001.3, 3002.0 - 3002.4
django37.52.2 - 2.2.24, 3.1 - 3.1.13, 3.2 - 3.2.9
apache-airflow19.8<=1.10.10
celery10*<=5.2.1
lxml17.1<=4.6.4
mistune19.830.0.0, 31.0.0
products_genericsetup15.3<=2.1.0
products_pluggableauthservice16.1<=2.6.0
pyyaml19.85.1 - 5.1.1
rsa15.92.1 - 4.6
sosreport13.319.10.0, 14.04.0, 18.04.0, 16.04.0, 19.04.0
vault_cli19.10.7.0 - 2.2.0


1 Affected Library refers to the open source library that contains newly disclosed CVEs.

2 # of CVEs refers to number of newly disclosed CVEs over the past week.

3 Highest CVE Score refers to the highest CVSS Score amongst the newly disclosed CVEs over the past week. Those omitted in dashes are yet to be determined by MITRE and NVD.

4 Affected versions refers to the versions of affected library that contains the newly disclosed CVEs.



Affected libraries may also exist in your transitive dependencies.

Scantist helps you find and fix your vulnerabilities instantly. Sign up for free and start scanning now.

We support other languages upon request. Subscribe to receive our weekly CSA alerts straight to your inbox.