Scantist CSA: Curated Security Advisory (13 May 2021)

Scantist CSA: Curated Security Advisory (13 May 2021)

Scantist Admin

Scantist Admin

- Curated Security Advisory

Scantist CSA:
Curated Security Advisory (13 May 2021)

Data is crawled between 5 to 12 May 2021

Java

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
com.vaadin:flow-server67.51.0.0 – 2.5.2, 3.0.0 – 6.0.5
com.fasterxml.jackson.core:jackson-databind58.1<2.9.10.8, 2.10.0 – 2.10.5
org.eclipse.jetty:jetty-project47.57.2.2 – 9.4.38, 10.0.0.alpha0 – 10.0.1, 11.0.0.alpha0 – 11.0.1
org.openapitools:openapi-generator33.3<5.1.0
apache:ofbiz29.8<17.12.07
com.vaadin:vaadin-server27.57.0.0 – 7.7.21, 8.0.0 – 8.8.4
org.apache.shiro:shiro-spring29.8<1.6.0, 1.7.0
com.alibaba.nacos:nacos-client29.8<1.4.1
com.vaadin:flow-client17.15.0.0 – 5.0.4, 6.0.0 – 6.0.4
org.apache.unomi:unomi-wab19.8<=1.5.1
org.apache.unomi:unomi19.8<=1.5.1
org.apache.unomi:unomi-kar19.8<=1.5.1
org.apache.unomi:unomi-persistence-elasticsearch-core19.8<=1.5.1
org.apache.unomi:unomi-plugins-base19.8<=1.5.1
org.apache.unomi:unomi-root19.8<=1.5.1
org.apache.unomi:unomi-services19.8<=1.5.1
org.cryptacular:cryptacular17.5<1.2.4
org.apache.tika:tika15.5<=1.25
org.eclipse.jetty:jetty-server15.39.4.6.v20170531 – 9.4.36.v20210114, 10.0.0, 11.0.0
org.eclipse.jetty:jetty-webapp17<=9.4.32.v20200930, 10.0.0 – 10.0.0.beta2, 11.0.0 – 11.0.0.beta2
org.infinispan:infinispan-server-runtime16.1<11.0.0.Final
ca.uhn.hapi.fhir:hapi-fhir-base10*<5.4.0
org.sonatype.nexus:nexus-repository16.13.0 – 3.30.1
org.apache.unomi:shell-commands19.8<=1.5.1
org.apache.tapestry:tapestry-core17.55.4.0 – 5.6.3, 5.7.0 – 5.7.1
com.nimbusds:nimbus-jose-jwt19.8<7.9
org.apache.druid:druid-core18.8<0.21.0
com.vaadin:vaadin-compatibility-server10*8.0.0 – 8.12.4
com.google.guava:guava13.3<30.0.0
com.vaadin:vaadin-text-field-flow17.52.04 – 2.3.2, 3.0.0 – 4.0.2
io.netty:netty-codec-http215.9<4.1.61.Final
org.apache.activemq:activemq-jaas17.5<=5.15.12, 5.16.0
org.apache.activemq:artemis-server17.5<2.16.0
org.apache.hadoop:hadoop-ozone17.5<1.1.0
org.apache.shiro:shiro-web17.5<1.6.0
org.apache.logging.log4j:log4j13.7<2.13.2
org.apache.maven:maven-core19.1<3.8.1
org.apache.shiro:shiro-core19.8<1.7.0
org.apache.shiro:shiro-guice17.5<1.6.0
apache:tomcat14.87.0.0 – 7.0.99, 8.5.0 – 8.5.50, 9.0.0m1 – 9.0.30
org.apache.shiro:shiro-spring-boot-web-starter17.5<1.6.0
pivotal_software:spring_framework16.5<=4.2.9, 4.3.0 – 4.3.28, 5.0.0 – 5.0.18, 5.1.0 – 5.1.17, 5.2.0 – 5.2.8


JavaScript

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
etherpad:etherpad47.5<1.8.3
mixme29.1<=0.5.0
jquery26.11.0.3 – 3.4.1
@ckeditor/ckeditor5-font16.5<=26.0.0
strapi10*3.6.0
safe-flat19.82.0.0 – 2.0.1
node-red16.5<1.2.8
node-mydomoathome17.50.2.4
highcharts10*<9.0.0
git-parse10*<=1.0.4
ftp-srv19.1<2.19.6, 3.0.1 – 3.1.1, 4.3.0 – 4.3.3
exiftool-vendored.pl17.8<12.25.0
exiftool-vendored.exe17.8<12.25.0
@ckeditor/ckeditor5-engine16.5<=26.0.0
electron18.8<10.4.4, 12.0.0 – 12.0.5
elasticsearch14.37.6.0 – 7.11.0
dynamoose19.82.0.0 – 2.6.0
browserlist15.34.0.0 – 4.16.4
@prisma/sdk17.2<2.20.0
@ckeditor/ckeditor5-widget16.5<=26.0.0
@ckeditor/ckeditor5-paste-from-office16.5<=26.0.0
@ckeditor/ckeditor5-media-embed16.5<=26.0.0
@ckeditor/ckeditor5-markdown-gfm16.5<=26.0.0
@ckeditor/ckeditor5-list16.5<=26.0.0
@ckeditor/ckeditor5-image16.5<=26.0.0
ueberdb217.5<0.4.4


Python

Affected Library 1# of CVEs 2Highest CVE Score 3Affected Versions 4
django20*2.2 – 2.2.21, 3.1 – 3.1.9, 3.2 – 3.2.1
localstack20*0.12.6
pygments27.51.1.0 – 2.7.3
salt27.8<=3002.6
apache_airflow16.1<1.10.15, 2.0.0 – 2.0.1
apache_superset16.1<=1.0.1
babel17.82.9.0
django_filter17.5<2.4.0
eventlet10*0.31.0
impacket10*0.9.22
python-markdown2_project:python-markdown217.51.0.1.18 – 2.3.9


1 Affected Library refers to the open source library that contains newly disclosed CVEs.

2 # of CVEs refers to number of newly disclosed CVEs over the past week.

3 Highest CVE Score refers to the highest CVSS Score amongst the newly disclosed CVEs over the past week. Those omitted in dashes are yet to be determined by MITRE and NVD.

4 Affected versions refers to the versions of affected library that contains the newly disclosed CVEs.



Affected libraries may also exist in your transitive dependencies.

Let Scantist help you identify your dependencies and vulnerabilities immediately. Sign up for free and start scanning now.

We support other languages upon request. Subscribe to receive our weekly CSA alerts straight to your inbox.